Lab50. eBGP Peering

Posted: February 10, 2014 in BGP, Cisco
Tags: , , ,

eBGP Peering

Yak, setelah maenan iBGP sekarang udah beda AS nih. . .

jadi ada 2 AS, AS 12 sama AS 3, nah gimana carane ?

piye carane ?

yok ikutin. . .

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
router rip                                    ( nah ini buat hubungin antar loopback R1 dan R2 yang sama AS itu lho )
network 1.0.0.0
network 12.0.0.0
no auto-summary
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255      ( advertise lo1 dan network s0/0 biar R3 bisa ping ke R1 )
network 12.12.12.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 12                               ( neighbor loopback R2 nya )
neighbor 2.2.2.2 update-source Loopback0
no auto-summary

R2

interface Loopback0                                          ( buat neighbor di R1 nya )
ip address 2.2.2.2 255.255.255.255
!
interface Loopback1                                               ( buat di advertise di network BGP nya )
ip address 22.22.22.22 255.255.255.255
!
interface FastEthernet0/0                                               ( buat ke AS 3 )
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0                                                   ( buat ke R1 )
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
router rip                                       ( buat hubungin  R1 dan R2 biar komunikasi BGP nya via loopback )
network 2.0.0.0
network 12.0.0.0
no auto-summary
!
router bgp 12
no synchronization
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255            ( ini yang loopback nya di advertise di bgp )
network 23.23.23.0 mask 255.255.255.0             ( network yang antara R2 dan R3 biar R1 bisa reachable )
neighbor 1.1.1.1 remote-as 12                            ( komunikasi BGP for R1 and R2 )
neighbor 1.1.1.1 update-source Loopback0        ( komunikasi nya biar via loopback )
neighbor 23.23.23.3 remote-as 3                        ( komunikasi via Physical Interface nya )
no auto-summary

Coba cek show ip bgp sumary, show ip route, ping ke loopback antar AS. . .

R1 eBGP

R3 eBGP

Nah inti nya kayak gitu. . .

Joss Lab50. Challenge Accepted. . .

😀

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s