Lab48. Introduction iBGP

Posted: February 10, 2014 in BGP, Cisco
Tags: , ,

iBGP

BGP itu apaan sih ?

Kan kalo kemaren2 kan kita udah belajar tentang IGP ( Interior Gateway Protocol )

Yang tentang ngehubungin Router – Router kayak RIP, OSPF, EIGRP,

Nah kalo BGP ini ngehubungin Antar AS. . .

Sedangkan IGP itu Beroperasi nya di dalem AS. . .

Kalo EGP berarti ngehubungin IGP IGP tapi beda AS. . .

BGP ini ngehubungin antar AS contoh kayak SPEEDY sama FASTNET. . .

SPEEDY ama FASTNET punya AS beda2. . .

AS speedy dan Fastnet di dapet dari IANA ( Internet Assigned Numbers Authority )

AS BGP itu ibarat IP, ada yang public ada yang private. . .

Kalo 1 – 64512 itu Public sedangkan 64512 – 65535 ( 1023 ) buat private

BGP pake TCP port 179 untuk kirim packet nya. . .

Kalo Router2 yang saling terhubung disebut BGP Speaker

Nah sekarang kita bakalan belajar tentang iBGP ( Internal BGP )

Jadi menghubungkan antar router yang sama AS nya. . .

Pertama config interface sama loopback nya. . .

IDN_R1(config)#int f0/0
IDN_R1(config-if)#ip address 12.12.12.1 255.255.255.0

IDN_R1(config)#int loopback 0
IDN_R1(config-if)#ip address 1.1.1.1 255.255.255.255

begitu juga di R2 nya. . .

IDN_R2(config)#int f0/0
IDN_R2(config-if)#ip address 12.12.12.2 255.255.255.0

IDN_R2(config)#int loopback 0
IDN_R2(config-if)#ip address 2.2.2.2 255.255.255.255

Setelah di buat interface nya dan loopback sekarang kita buat routing BGP nya. . .

IDN_R1(config)#router bgp 12 ( AS NUMBER NYA )
IDN_R1(config-router)#neighbor 12.12.12.2 remote-as 12   ( 12.12.12.2 lawan nya yang direct connect, remot-as = as nya router yang direct )

IDN_R2(config)#router bgp 12 ( AS number nya kan sama )
IDN_R2(config-router)#neighbor 12.12.12.1 remote-as 12

Untuk veryfikasi nya pake show ip bgp summary

IDN_R1#show ip bgp su
BGP router identifier 1.1.1.1, local AS number 12
BGP table version is 3, main routing table version 3
2 network entries using 240 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 748 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.2      4    12      15      17        3    0    0 00:12:05        1

IDN_R2(config)#do sh ip bgp su
BGP router identifier 2.2.2.2, local AS number 12
BGP table version is 3, main routing table version 3
2 network entries using 240 bytes of memory
2 path entries using 104 bytes of memory
3/2 BGP path/bestpath attribute entries using 372 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
Bitfield cache entries: current 1 (at peak 1) using 32 bytes of memory
BGP using 748 total bytes of memory
BGP activity 2/0 prefixes, 2/0 paths, scan interval 60 secs

Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
12.12.12.1      4    12      19      18        3    0    0 00:14:40        1
IDN_R2(config)#

Nah kalau udah saling adjency sekarang kita advertise network loopback ke dalam BGP nya. . .

IDN_R1(config-router)#network 1.1.1.1 mask 255.255.255.255

IDN_R2(config-router)#network 2.2.2.2 mask 255.255.255.255

Kalau udah di advertise coba di cek ip route nya di R1 dan di R2, abis itu ping ke loopback ke lawan Router nya

r1 idn bgp

r2 idn ibgp

Yup, udah bisa. . .

Congratulations😀

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s