Lab34. OSPF Summarization – Area Range

Posted: February 4, 2014 in Cisco, OSPF
Tags: , , ,

Konfig Dasar EIGRPArea 0

Kalo yang sebelum nya kita ngomongin Filtering Ganjil dan Genap, sekarang kita bakalan melakukan Penggabungan atau lebih dikenal “Summarization”

Nah inget kalo Internal Route (ABR) pake perintah “Area x Range”
Kalo External Route (ASBR) pake perintah “summary-address”

Coba perhatiin config berikut. . .

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 100.100.100.1 255.255.255.255
!
interface Loopback2
ip address 100.100.100.2 255.255.255.255
!
interface Loopback3
ip address 100.100.100.3 255.255.255.255
!
interface Loopback4
ip address 100.100.100.4 255.255.255.255
!
interface Loopback5
ip address 100.100.100.5 255.255.255.255
!
interface Loopback6
ip address 100.100.100.6 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
area 1 range 100.100.100.0 255.255.255.248           ( di “summarize” disini )
network 100.100.100.1 0.0.0.0 area 1                      ( pada dimasukin loopback ke area 1 )
network 100.100.100.2 0.0.0.0 area 1
network 100.100.100.3 0.0.0.0 area 1
network 100.100.100.4 0.0.0.0 area 1
network 100.100.100.5 0.0.0.0 area 1
network 100.100.100.6 0.0.0.0 area 1
network 0.0.0.0 255.255.255.255 area 0

R2

interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 2
router-id 2.2.2.2
log-adjacency-changes
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 23.23.23.2 0.0.0.0 area 0

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 3
router-id 3.3.3.3
log-adjacency-changes
network 3.3.3.3 0.0.0.0 area 0
network 23.23.23.3 0.0.0.0 area 0

Untuk Veryfikasi Coba Show Ip Route di R3, apakah sudah ter-summarize ?

summary

Nah kan dah ke “Summary” dia. . .

Coba kalo diliat di Routing Table nya R1,

R1(config)#do sh ip rou
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 12.12.12.2, 00:24:05, Serial0/0
100.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
C       100.100.100.4/32 is directly connected, Loopback4
C       100.100.100.5/32 is directly connected, Loopback5
C       100.100.100.6/32 is directly connected, Loopback6
O       100.100.100.0/29 is a summary, 00:24:05, Null0
C       100.100.100.1/32 is directly connected, Loopback1
C       100.100.100.2/32 is directly connected, Loopback2
C       100.100.100.3/32 is directly connected, Loopback3
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/75] via 12.12.12.2, 00:24:10, Serial0/0
23.0.0.0/24 is subnetted, 1 subnets
O       23.23.23.0 [110/74] via 12.12.12.2, 00:24:10, Serial0/0
12.0.0.0/24 is subnetted, 1 subnets
C       12.12.12.0 is directly connected, Serial0/0

Kalo di OSPF, discard route bakalan otomatis muncul kalo di summary, untuk hindarin terjadi adanya forwarding loop, diapus aja. Cara nya ?

R1(config)#router ospf 1
R1(config-router)#no discard-route

Coba liat sekali lagi. . .

R1(config-router)#do sh ip rou
Codes: C – connected, S – static, R – RIP, M – mobile, B – BGP
D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area
N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2
E1 – OSPF external type 1, E2 – OSPF external type 2
i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2
ia – IS-IS inter area, * – candidate default, U – per-user static route
o – ODR, P – periodic downloaded static route

Gateway of last resort is not set

1.0.0.0/32 is subnetted, 1 subnets
C       1.1.1.1 is directly connected, Loopback0
2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 12.12.12.2, 00:00:03, Serial0/0
100.0.0.0/32 is subnetted, 6 subnets
C       100.100.100.4 is directly connected, Loopback4
C       100.100.100.5 is directly connected, Loopback5
C       100.100.100.6 is directly connected, Loopback6
C       100.100.100.1 is directly connected, Loopback1
C       100.100.100.2 is directly connected, Loopback2
C       100.100.100.3 is directly connected, Loopback3
3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/75] via 12.12.12.2, 00:00:05, Serial0/0

Oke udah gak ada. . .

Joss !!!

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s