Lab30. OSPF Virtual Link

Posted: February 3, 2014 in Cisco, OSPF
Tags: , , ,

ospf virtual link

Yang namanya OSPF, semua harus terhubung ke Area 0, kalau gak terhubung ke area 0 ga mau terhubung dia.

Kalo diliat dari topology di atas R3 kan ga terhubung ke area 0 tuh.

Nah salah satu cara nya biar bisa terhubung ke area 0 pake virtual link.

Jadi seolah olah dia terhubung langsung ke area 0.

R1

interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.1 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 1
router-id 1.1.1.1
log-adjacency-changes
 area 1 virtual-link 2.2.2.2         ( di R1 di setting area yang saling terhubung, virtual link router-id )
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 1

R2

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.2 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 12.12.12.2 255.255.255.0
clock rate 2000000
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/1
no ip address
shutdown
clock rate 2000000
!
router ospf 2
router-id 2.2.2.2
log-adjacency-changes
 area 1 virtual-link 1.1.1.1                        ( yang arah ke R1 )
 area 2 virtual-link 3.3.3.3                      ( yang arah ke R3 )
network 2.2.2.2 0.0.0.0 area 1
network 12.12.12.2 0.0.0.0 area 1
network 23.23.23.2 0.0.0.0 area 2

R3

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 23.23.23.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router ospf 3
router-id 3.3.3.3
log-adjacency-changes
 area 2 virtual-link 2.2.2.2                                      ( yang arah ke R2 )
network 3.3.3.3 0.0.0.0 area 3
network 23.23.23.3 0.0.0.0 area 2

Untuk Veryfikasi mari kita Show Ip Route pada R1, R3

 ospf virtual link r1

Show Ip Route Pada R1

ospf virtual link r3

Show Ip Route Pada R3

ping ke lopback R1

Ping dari R3 ke loopback R1

ping ke lopback R3

 

Ping dari R1 ke loopback R3

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s