Lab25. Mutual Redistribution – Route Tagging

Posted: February 3, 2014 in Cisco
Tags: , , , ,

Redistribution

 

Okeeeh kali ini mau share tutor biar ngehubungin antara EIGRP dan RIP, di pertengahan antara R7 dan R8 harus difilter gitu, jadi yang boleh lewat hanya tertentu. . .

patokan nya disini

route-map EIGRP-ke-RIP deny 10
match tag 120
!
route-map EIGRP-ke-RIP permit 20
set tag 90
!
route-map RIP-ke-EIGRP deny 10
match tag 90
!
route-map RIP-ke-EIGRP permit 20
set tag 120
!

yok lah langsung config nya. . .

 

R5
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 13.13.13.1 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
network 13.13.13.1 0.0.0.0
no auto-summary

R6

interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface FastEthernet0/0
ip address 12.12.12.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 24.24.24.2 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 24.24.24.2 0.0.0.0
no auto-summary

R7

interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
ip address 13.13.13.3 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 35.35.35.3 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
redistribute rip metric 1 1 1 1 1 route-map RIP-ke-EIGRP
network 3.3.3.3 0.0.0.0
network 13.13.13.3 0.0.0.0
no auto-summary
!
router rip
version 1
redistribute eigrp 1 metric 1 route-map EIGRP-ke-RIP
network 35.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
route-map EIGRP-ke-RIP deny 10
match tag 120
!
route-map EIGRP-ke-RIP permit 20
set tag 90
!
route-map RIP-ke-EIGRP deny 10
match tag 90

route-map RIP-ke-EIGRP permit 20
set tag 120

R8

interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
ip address 24.24.24.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 46.46.46.4 255.255.255.0
duplex auto
speed auto
!
router eigrp 1
redistribute rip metric 1 1 1 1 1 route-map RIP-ke-EIGRP
network 24.24.24.4 0.0.0.0
no auto-summary
!
router rip
redistribute eigrp 1 metric 1 route-map EIGRP-ke-RIP
network 4.0.0.0
network 46.0.0.0
!
ip forward-protocol nd
!
!
no ip http server
no ip http secure-server
!
!
!
!
route-map EIGRP-ke-RIP deny 10
match tag 120
!
route-map EIGRP-ke-RIP permit 20
set tag 90
!
route-map RIP-ke-EIGRP deny 10
match tag 90
!
route-map RIP-ke-EIGRP permit 20
set tag 120
!

R9

interface Loopback0
ip address 5.5.5.5 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 35.35.35.5 255.255.255.0
duplex auto
speed auto
!
router rip
network 5.0.0.0
network 35.0.0.0
network 56.0.0.0

R10

interface Loopback0
ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
ip address 56.56.56.6 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 46.46.46.6 255.255.255.0
duplex auto
speed auto
!
router rip
network 6.0.0.0
network 46.0.0.0
network 56.0.0.0

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s