Apa itu EIGRP ?!?!

Posted: January 13, 2014 in Cisco, EIGRP
Tags: ,

Oiiii, pada pembahasan kali in saya akan menjelaskan apa itu EIGRP secara luas.
EIGRP (Enhanced Interior Gateway Routing Protocol) adalah routing protocol yang hanya di adopsi oleh router cisco atau sering disebut sebagai proprietary protocol pada cisco. Dimana EIGRP ini hanya bisa digunakan sesama router cisco saja. Bgmn bila router cisco digunakan dengan router lain spt Juniper, Hwawei, dll menggunakan EIGRP??? Seperti saya bilang diatas, EIGRP hanya bisa digunakan sesama router cisco saja. EIGRP ini sangat cocok digunakan utk midsize dan large company. Karena banyak sekali fasilitas2 yang diberikan pada protocol ini.

Hal-hal dasar yang perlu diketahui
EIGRP sering disebut juga hybrid-distance-vector routing protocol, karena EIGRP ini terdapat dua tipe routing protocol yang digunakan, yaitu:
– distance vector, dan
– link state.

Utk tipe2 routing protocol akan saya tambahkan sehabis penjelasan tentang EIGRP.
EIGRP ini pengembangan dari routing protocol IGRP (distance vector), prorpietary cisco juga. Perbandingan (bukan perbedaan) antar IGRP dan EIGRP di bagi menjadi beberapa kategori:
1. Compability mode
2. Metric colocation
3. Hop count
4. Automatic protocol redistribution
5. Route tagging

EIGRP dan IGRP dapat di kombinasikan satu sama lain karena EIGRP adalah hanya pengembangan dari IGRP.
Dalam perhitungan untuk menentukan path/jalur manakah yang tercepat/terpendek, EGIRP menggunakan algortima DUAL (Diffusing-Update Algorithm) dalam menentukannya.
EIGRP mempunyai 3 table dalam menyimpan informasi networknya:
1. Neighbor table
2. Topology table
3. Routing table
Penjelasan :
1. Neighbor table : Tabel yang paling penting dari tabel2 yang lainnya. di tabel ini menyimpan list tentang router2 tetangganya. Setiap ada router baru yg dipasang,address dan interface lgsg dicatat di tabel ini.
2. Topology table : Tabel ini dibuat untuk memenuhi kebutuhan dari Routing table dalam 1 autonomous system (kya sistem area di OSPF). DUAL mengambil informasi dari “neighbor tabel” dan “topology table” untuk melakukan kalkulasi “lowest cost routes to each destination”. Setelah melakukan kalkulasi akan ada yang namanya “successor route”. Successor route ini disimpan di tabel ini juga lho.
3. Routing table : menyimpan the best routes to a destination. Informasi tersebut diambil dari “topology table”
Internal Route : Route-route yang berasal dari dalam suatu autonomous system dari router2 yang menggunakan routing protocol EIGRP, yang menjadi anggota dari autonomous system adalah yang mempunyai ADN dari EIGRP yang sama dan mempunyai autonomous system yang sama juga. ADN internal route adalah 90.
External Route : Route-route yang muncul dari luar autonomous system, baik redistribution secara manual maupun secara otomatis.

Cara Kerja dari EIGRP
EIGRP akan mengirimkan hello packet utk mengetahui apakah router2 tetangganya masih hidup ataukah mati. Pengiriman hello packet tersebut bersifat simultant, dalamhello packet tersebut mempunyai hold time, bila dalam jangka waktu hold time router tetangga tidak membalas.. maka router tsb akan dianggap mati. Biasanya hold time itu 3x waktunya hello packet, hello packet defaultnya 15 second. Lalu DUAL akan meng-kalkulasi ulang utk path2nya. Hello packet dikirim secara multicast ke IP Address 224.0.0.10.

Setting Konfigurasi Untuk Topology Diatas :

1. Router Pertama :

Building configuration…

Current configuration : 783 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524I8AO
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.10.10.2 255.255.255.0
!
interface Serial0/1/1
no ip address
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 1.0.0.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

2. Router Kedua :

Building configuration…

Current configuration : 836 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524SEQ8
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 10.10.10.1 255.255.255.0
clock rate 125000
!
interface Serial0/1/1
ip address 192.168.0.1 255.255.255.0
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 10.0.0.0
network 192.168.0.0
network 2.0.0.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

3. Router Ketiga :

Building configuration…

Current configuration : 829 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!

Router(config)#do sh ru
Building configuration…

Current configuration : 829 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Router
!
!
!
!
!
!
!
!
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15247RIA
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 192.168.0.2 255.255.255.0
!
interface Serial0/1/1
ip address 192.168.0.2 255.255.255.0
clock rate 125000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router eigrp 10
network 192.168.0.0
network 3.0.0.0
no auto-summary
!
ip classless
!
!
!
!
!
!
!
line con 0
!
line aux 0
!
line vty 0 4
login
!
!
!
end

Source: http://united-yand.blogspot.com/2012/06/apa-itu-eigrp.html

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s